App Down

Incident Report for Asana

Postmortem

Incident: AWS infrastructure had an outage affecting core services, which our application depends on, in the Virginia (us-east-1) region. The initial impact to our services is covered by https://status.asana.com/incidents/zfdtyvckl5k2; this covers the second major impact to our services.

Impact: Starting at 2025-10-20 14:58 UTC, our application was down for approximately 10% of our users. By 15:08 UTC the application was completely down for all users We saw some improvement in internal error rates around 17:06 UTC resulting in intermittent availability. We did not see full infrastructure recovery until approximately 19:50 UTC and our traffic fully recovered by 20:29 UTC. This affected all regions because we store some global state and shared application configuration in the Virginia region.

Moving forward: We are working on ways to reduce the impact of single region outages, including for this region, to limit the impact and improve options for recovery.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Oct 23, 2025 - 16:08 UTC

Resolved

Asana is now fully operational, and all services are performing normally. API traffic and client access have been fully restored, and we’re no longer seeing elevated error rates or latency.

This incident was related to an earlier AWS service disruption. We’ll continue to monitor performance closely, but Asana is back to normal.
Posted Oct 20, 2025 - 20:34 UTC

Monitoring

Asana is functional again. We’ve begun re-enabling API traffic and are gradually allowing traffic from all clients. Most functionality is coming back online, though some users may still experience intermittent errors or slower performance while systems stabilise.
Posted Oct 20, 2025 - 19:54 UTC

Update

We are continuing to work on restoring access to Asana. This outage is related to the ongoing AWS service disruption, which is affecting many applications and customers globally (https://health.aws.amazon.com/health/status).

Our engineers are actively deploying mitigation strategies to restore Asana functionality and reduce our reliance on affected services. We're observing some recovery in foundational infrastructure, and are working towards restoring core app functionality.
Posted Oct 20, 2025 - 18:43 UTC

Update

We are continuing to work on resolving the issue impacting access to Asana. This outage is related to the ongoing AWS service disruption, which is affecting many applications and customers globally (https://health.aws.amazon.com/health/status). Our team is closely monitoring AWS recovery efforts and will restore full functionality as soon as possible.
Posted Oct 20, 2025 - 16:55 UTC

Update

We are still working on fixing the issue, this is affecting most of our users
Posted Oct 20, 2025 - 15:07 UTC

Identified

We are currently investigating an issue which affects about 10% of our users, this is a continuation of the AWS outage that happened earlier today
Posted Oct 20, 2025 - 14:28 UTC
This incident affected: US (App, API, Mobile, Automations and Background Actions, Webhooks and Event Streams, Notifications).