Some Asana features have been affected by an Amazon Web Services outage
Incident Report for Asana
Postmortem

Incident:

On June 13, 2023, AWS had an outage for the AWS Lambda service for about 3.5 hours. This outage led certain Asana features, most notably webhooks, to not be available to Asana users.

Impact:

Asana users experienced an outage in webhooks functionality for about 3 hours, with a degradation for approximately another 40 mins. During the outage, users of webhooks were not able to receive webhook events. The outage led to a delay in delivery of these events and there was no loss of data.

Moving forward:

We are enhancing  our operational tools  in order to be more resilient to this type of outage and to minimize any potential impact of AWS unavailability.

Posted Jun 22, 2023 - 23:51 UTC

Resolved
This incident has been resolved.
Posted Jun 14, 2023 - 00:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 14, 2023 - 00:20 UTC
Update
We currently are experiencing an issue with webhooks and remote jobs being in a degraded state (Ex: attachments functionality is affected) jobs and are working on this issue
Posted Jun 13, 2023 - 23:52 UTC
Update
Some Asana features have been affected by an Amazon Web Services outage. We're are currently working on this issue and we apologise for the inconvenience. For the latest updates, please check https://status.aws.amazon.com/

The Asana app is functional, except for the following:
- Webhooks are down
- Remote jobs are in a degraded state. Ex: attachments functionality is affected
- OneDrive attachments
- Incoming emails not working
Posted Jun 13, 2023 - 20:42 UTC
Investigating
We are currently experiencing some difficulties; Our Development Team is currently investigating this issue and we're hoping to get it fixed as soon as possible. Sincere apologies for the inconvenience; if you're impacted by this issue, please keep an eye on this page for the latest updates.

The Asana app is functional, except for the following:
- Webhooks are down
- Remote jobs are in a degraded state. Ex: attachments functionality is affected
- OneDrive attachments
- Incoming emails not working
Posted Jun 13, 2023 - 20:31 UTC
This incident affected: US (Webhooks and Event Streams).