Asana down in US

Incident Report for Asana

Postmortem

Incident: Starting at 2025-02-05 21:05 UTC, a configuration change caused a large increase in server logs, overloading logging infrastructure and causing server restarts. This caused cascade failure as other servers were overloaded. The configuration change was reverted, and our application recovered after the servers restarted, with recovery by around 2025-02-05 21:30.

Impact: Users saw errors loading our application and loading data within the application. No customer data was lost.

Moving forward: We have removed the source of logs which resulted in overload, and are improving monitoring and resilience of the system which triggered failure. We will also be moving to staged configuration rollouts to help reduce or avoid customer impact for similar issues.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Feb 07, 2025 - 22:46 UTC

Resolved

This incident has been resolved.
Posted Feb 05, 2025 - 21:54 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 05, 2025 - 21:35 UTC

Update

We have made configuration changes and are monitoring for recovery.
Posted Feb 05, 2025 - 21:34 UTC

Update

We are continuing to investigate this issue.
Posted Feb 05, 2025 - 21:22 UTC

Investigating

We are seeing a high rate of errors for the Asana application in the US region.
Posted Feb 05, 2025 - 21:19 UTC
This incident affected: US (App, API).