Page load failures
Incident Report for Asana
Postmortem

Incident: An off-peak routine update of our service handling new page loads caused us to deploy code that depended on an artifact that wasn't yet available. The net effect was that all traffic attempting to do a fresh page load was broken for 48 minutes from June 28 5:52 pm PT to June 28 6:39 pm PT.

Impact: Asana was unavailable to new page loads, but existing sessions continued to work as normal.

Moving forward: This incident involved interaction across teams and systems. Our postmortem of this event identified operational and tooling changes to reduce the likelihood of incidents -- and decrease the time to resolution. We have an ongoing 5 Whys analysis for this incident.

Posted Jul 09, 2024 - 20:49 UTC

Resolved
We've resolved the issue where some users were unable to load the Asana application. We're investigating the root cause. We apologize for the inconvenience.
Posted Jun 28, 2024 - 17:50 UTC