Errors accessing Asana
Incident Report for Asana
Postmortem

Incident:

An experimental flag was enabled that changed initial page loading behavior. With the flag enabled, users were inadvertently directed to load a code version that was not servable by all groups of servers. Subsequent requests would fail when requesting this incompatible version, including requests to report the page load errors. 

Impact: 

From 16:52 to 18:59 UTC, 10% of users were unable to load the Asana application in the desktop app or web browser. Existing sessions, as well as mobile and API traffic, were not impacted.

Moving forward:

We reverted the configuration change and identified gaps in our monitoring. We are adding monitoring and alerting for version mismatches during page load in order to more quickly identify similar regressions in the future.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Sep 18, 2024 - 16:56 UTC

Resolved
This incident has been resolved.
Posted Sep 16, 2024 - 19:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 16, 2024 - 19:16 UTC
Investigating
We've received reports of users unable to access the Asana web and desktop application and are currently investigating.
Posted Sep 16, 2024 - 18:56 UTC
This incident affected: US (App), EU (App), Japan (App), and Australia (App).