Outage
Incident Report for Asana
Postmortem

Incident: Databases containing authentication information experienced increased load and reduced throughput due to a database migration.

Impact: On 2023-11-28 from 18:00-18:25 PST, the Asana API was operating in a degraded state and/or unavailable. Asana Mobile and API users experienced increased response times and errors during this incident.

Moving forward: To prevent similar incidents, Asana has increased database compute provisioning and has developed monitoring around the root cause.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Dec 11, 2023 - 18:50 UTC

Resolved
Incident: Databases containing authentication information experienced increased load and reduced throughput due to a database migration.

Impact: On 2023-11-28 from 18:00-18:25 PST, the Asana API was operating in a degraded state and/or unavailable. Asana Mobile and API users experienced increased response times and errors during this incident.

Moving forward: To prevent similar incidents, Asana has increased database compute provisioning and has developed monitoring around the root cause.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.
Posted Nov 29, 2023 - 02:00 UTC