Partial Outage (OAuth Apps unavailable for 1 hour from 19:18-20:16 UTC)
Incident Report for Asana
Postmortem

Incident: On 2024-02-08 from 19:19 UTC to 20:16 UTC one of our API authentication mechanisms experienced an outage, resulting in a 44% failure rate for API requests during the incident across all regions. The outage was caused by a backwards-incompatible dependency upgrade that was not caught before being deployed to production. Asana's status page was updated at 19:30 UTC to reflect a partial outage and we finished rolling back the deployment at 20:15 UTC.

Impact: The outage impacted all customers accessing the API with an OAuth bearer token, directly or through the use of an app integration. API access using personal access tokens and via service accounts was not impacted by this outage. No data loss occurred during the incident.

Moving forward: We will enhance our monitoring with test cases for the specific failure we observed. We are also investing in changes to our deployment process to better catch issues like this prior to deployment to production.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Feb 13, 2024 - 05:59 UTC

Resolved
Our engineers have fixed the issue and Asana is now running normally. Again sincere apologies for any inconvenience this caused!

This issue only impacted the API component.
Posted Feb 08, 2024 - 19:30 UTC