Partial downtime for Asana's MCP server

Incident Report for Asana

Postmortem

Incident:

Cloudflare experienced an outage that impacted the Workers KV service, a storage infrastructure service our MCP server relies on. This resulted in increased error rates and failed requests for a portion of our MCP traffic over the span of 3 hours.

Impact: 

Approximately 100 users making requests to the MCP server received error responses or were unable to reach the server from 2025-11-18 11:20 UTC through 14:20 UTC.

Moving forward:

We are investing in our MCP Server to improve its resilience to KV store outages, and are investigating ways to reduce the overall impact of Cloudflare outages.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Nov 21, 2025 - 00:30 UTC

Resolved

Asana's MCP server experienced partial unavailability for three hours due to an upstream provider outage. No data loss or security issues occurred during this outage.

This resulted in an increased rate of errors from 3:20 - 5:00 AM PT and some failed requests from 5:04 - 6:26 AM PT. The service fully recovered after the upstream provider resolved the issue.
Posted Nov 18, 2025 - 11:30 UTC