MCP Maintenance

Incident Report for Asana

Postmortem

Incident: From June 5th, 2025 through June 17th we disabled MCP (an opt-in API feature) for maintenance to address a vulnerability.

Impact: If your organization was using the MCP server and was impacted by this issue, we have already reached out to you directly with important details and next steps.

Moving forward: We've fixed the the bug which was identified. As part of our remediation efforts, we reset all connections to the MCP server. This means you'll need to manually reconnect your Asana instance to the MCP server.

Posted Jun 17, 2025 - 17:03 UTC

Resolved

Asana's MCP server is now operational.
Posted Jun 17, 2025 - 16:51 UTC

Update

We anticipate the MCP server will be back online by June 17, 17:00 UTC. We'll provide another update at that time or when the server is redeployed. Thank you for your patience as we work through this issue.
Posted Jun 16, 2025 - 23:54 UTC

Update

We identified a bug affecting our Model Context Protocol (MCP) server. Our engineering team has resolved the underlying issue and is now working to reinstate the server. We will post another update shortly with a time estimate.
Posted Jun 16, 2025 - 20:45 UTC

Monitoring

Asana's MCP server is undergoing maintenance. During this maintenance, MCP is unavailable to the customers who've opted-in.
Posted Jun 05, 2025 - 17:51 UTC
This incident affected: US (API), EU (API), Japan (API), and Australia (API).