Asana webapp unavailable

Incident Report for Asana

Postmortem

Incident: On 2026-01-22 the Asana App and all associated services had a service disruption due to dependency on a shared database used for storing metadata. This was triggered by a code path which caused overload for that database, followed by request queuing, timeouts, and errors.

Impact: From 17:33 - 17:57 UTC the Asana App and all associated services were unavailable. There was a further 14 minutes of partial downtime from 18:45 - 18:59 UTC affecting 10-20% of users, also triggered by dependency on this shared database.

Moving forward: We immediately rolled back our application code and added resources for this database. Going forward we will continue to reduce dependency on this shared database for common paths to reduce risk, and monitor for unexpected resource usage.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Jan 27, 2026 - 07:55 UTC

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 19:00 UTC

Update

Our error rates are back to normal baseline, and we don't expect an immediate recurrence. We'll create a post-mortem in the next few days with more details, including what happened and how we plan to prevent this going forward.
Posted Jan 22, 2026 - 18:38 UTC

Update

Error rates have dropped significantly, to about 2%. It's possible some users continue to see errors, but we expect most users to be able to use Asana.
Posted Jan 22, 2026 - 18:04 UTC

Update

We've identified the cause and have rolled back. Based on our monitoring, we should be recovered for some users.
Posted Jan 22, 2026 - 17:59 UTC

Update

We are continuing to investigate this issue.
Posted Jan 22, 2026 - 17:51 UTC

Investigating

We're investigating an outage, it looks like no one is able to reach the Asana webapp.
Posted Jan 22, 2026 - 17:48 UTC
This incident affected: US (App), EU (App), Japan (App), Australia (App), and Middle East (App).