Automation delay

Incident Report for Asana

Postmortem

Incident: Around 2025-08-17 23:35, a conflict occurred between two database management systems. For most Asana customers, database locks prevented execution of background actions, automations, and webhooks were delayed.

Impact: Users experienced delays in asynchronous operations, including automations and webhooks. Core application functions remained available and operational throughout the incident. No customer data was lost. The incident lasted approximately 2 hours, after which delayed operations ran normally.

Moving forward: Asana engineers completed an investigation into the root cause, and have implemented changes to prevent the conflict between these systems. We are also reviewing our upgrade and management processes to be resilient against similar issues in the future.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Aug 20, 2025 - 00:07 UTC

Resolved

Automations and background actions are back to normal operations for all Asana users and customers.
Posted Aug 18, 2025 - 02:43 UTC

Monitoring

The root cause of automation delay has been addressed, and controls are in place for automations and background actions to catch up on overdue work. Our engineers are monitoring metrics for recovery, and we expect Asana to return to full functionality shortly.
Posted Aug 18, 2025 - 01:41 UTC

Identified

Asana is currently observing delay for all automations and background actions. Engineers are currently taking steps to mitigate the impact of this delay, and are investigating further to address the root cause.
Posted Aug 18, 2025 - 01:01 UTC
This incident affected: US (Automations and Background Actions), EU (Automations and Background Actions), Japan (Automations and Background Actions), and Australia (Automations and Background Actions).