Degraded Performance
Incident Report for Asana
Postmortem

Incident: The Amazon Web Services availability zone where most of our EU customers are hosted went down. As soon as we learned this, we began our recovery process. With limited availability of all Amazon Web Services, the recovery took 3-4 hours. 

Impact: There was no data loss, and only partial access loss for 3 hours. 

Moving forward: As a result of this incident, Asana is working to be more resilient to single availability zone failures.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Aug 23, 2021 - 18:00 UTC

Resolved
This incident has been resolved.
Posted Jun 11, 2021 - 00:57 UTC
Monitoring
Root cause identified as an upstream AWS incident affecting only our EU cluster.
Service is now mostly recovered. We are monitoring the fix for any issues.
Posted Jun 11, 2021 - 00:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 10, 2021 - 23:53 UTC
Investigating
We are currently investigating this issue affecting only our EU cluster.
Posted Jun 10, 2021 - 20:51 UTC
This incident affected: US (App, API, Mobile, Automations and Background Actions, Webhooks and Event Streams).