Notifications and Background Actions delayed in EU

Incident Report for Asana

Postmortem

Starting on April 20th, 2026 at 10:00 AM PDT, a combination of scaled-up background action jobs in the EU and a recent change to how date time trigger volume is managed overloaded the system that processes resource intensive background action jobs. This caused multi-hour delays in email and inbox notifications in the EU and prevented date time triggers from executing in all regions. Engineers were first alerted on April 21st by our monitoring systems, but did not recognize the full scope of the incident until April 23rd. On April 23rd, the change to manage date time trigger volume was reverted and the problematic background action jobs were isolated. All delayed notifications were sent by April 24th, 11:30 AM PDT, and all delayed date time triggers were executed by April 27th, 4:00 AM PDT.

Posted Apr 30, 2026 - 00:43 UTC

Resolved

Between April 20th and April 24th, 60% of email and inbox notifications were delayed by at least one hour in EU. Notifications were delayed up to 3 days. Other resource intensive background actions were also impacted at a lesser rate.
Posted Apr 20, 2026 - 17:00 UTC