Asana down

Incident Report for Asana

Postmortem

Incident: At 2025-02-06 15:37 UTC, a configuration change caused some of our servers to crash, leading to complete downtime for 20 minutes. We rolled back the configuration, but this event triggered a cascade failure in network routing components; our systems recovered over the next 30 minutes, with full recovery by 2025-02-06 16:30.

Impact: Users were unable to use Asana during this event in all regions, with downtime including App, API, and Mobile. No customer data was lost.

Moving forward: We have added validation to prevent a repeat of this issue, and are updating our networking components to avoid this form of cascade failure. We will be moving to staged configuration rollouts to identify this class of issue without causing downtime for customer traffic.

Our metric considers a weighted average of uptime experienced by users at each data center. The number of minutes of downtime shown reflects this weighted average.

Posted Feb 07, 2025 - 22:48 UTC

Resolved

This incident has been resolved.
Posted Feb 06, 2025 - 16:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2025 - 16:02 UTC

Identified

We have identified a cause and are implemented a fix.
Posted Feb 06, 2025 - 15:52 UTC

Investigating

We are seeing elevated errors for App and API, and are investigating.
Posted Feb 06, 2025 - 15:38 UTC
This incident affected: US (App, API), EU (App, API), Japan (App, API), and Australia (App, API).